Workbook_Open() not firing

  • Workbook_Open() subs are not firing if I have another workbook open.
    The sub does fire if no other workbooks are open, but if another workbook is open, it doesn't fire.
    This is not workbook specific... it happens to any workbook with a Workbook_Open() sub.


    Code
    Private Sub Workbook_Open()
    'Load Initial UserForm
    
    
            If ThisWorkbook.Sheets("Project Info").Range("F2").Value = "" Then
                InitializeUserForm.Show
            End If
            
    End Sub


    Thoughts on what could be stopping the Workbook_Open sub from firing?


    TiA,

  • Re: Workbook_Open() not firing


    Just noticed another peculiarity...
    Comments aren't showing with mouse-over, on any but the first workbook opened.

  • Re: Workbook_Open() not firing


    No comments or suggestions... I'm a little surprised from this group.


    Anyway, issue is solved... I started over with a fresh workbook and redid everything, which now does as it should.


    I'd still be interested in theories behind the cause, as it would be a real SoB if I was further into a project and had to start over to get a fix.

  • Re: Workbook_Open() not firing


    I found the cause of the mouse-over and data validation dropdowns not working.
    On the 'Original' sheet, I have snapshots of sections of the 'Data' sheet to show company and client info.
    If these snapshots reference ranges on another workbook, things are fine, but once the reference is to a sheet/range within the same workbook, the mouse-over and data validation dropdowns stop working.
    I deleted the snapshots and all is well again.


    I'd still like some insight as to why this is occurring, and how to get snapshots without having this problem.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!