Re: Use Of Hash Sign In Macro
Quote from Dave Hawley
Oh, yes, soooo much easier to read. Except the 1 letter variables like x, y, i, j etc.
lRows or lngRow is so much easier to read and debug.
I guess that's a matter of taste. I generally write pretty strict Systems Hungarian in VB and Hungarian/RVBA notation in VBA, but my indexes for walking arrays are in most cases i, j and k, and on the rare occasion I need to nest another loop, m, n and p.
Once get used to i being the first dimension, j the second and k the third, it is in my opinion much easier to read than lngRow, lngCol and lngDepth.
I do agree that in VB where the syntax consists of semantic proper case/camel case words, using a single character variable looks a little out of place, but coming from other languages where the syntax is much less verbose, it feels much more natural to iterate with "i" than for instance with "loop_index".